Get in touch
Back
Maintenance

From midnight to 2 am ET, EquiLife will be introducing enhanced client authentication and single sign-on site wide

Completed 3 Sep at 01:37am EDT.

Equi.Life Store Labs Registration Labs Portal APIs and Managment Systems Customer Service Platform (Gorgias) EquiLife Coaching Portal
Completed

Maintenance completed

Posted 3 Sep at 01:37am EDT.
Started

This evening we introduced single-sign-on (SSO) across all client-facing systems, including the EquiLife store, myhealth platform and our labs registration process. Clients can now access all of their health information, schedule and attend heath coaching appointments, and purchase the labs and supplements they need faster and more easily than ever before.

Posted 3 Sep at 12:00am EDT.