Back
Downtime

Labs registration and labs admin systems are experiencing an unscheduled outage
Started 2 May at 11:12am EDT, resolved 2 May at 11:21am EDT.
Labs Registration
Labs Portal APIs and Managment Systems
Resolved
This issue has been resolved and all systems are now availlable.
Posted 2 May at 11:21am EDT.

Created
The Labs Registration and Labs Admin systems are currently unavailable. The EquiLife tech team is working to restore access. We apologize for the inconvenience.
Posted 2 May at 11:12am EDT.